After Effects missing from new project

I’m still pretty new to getting a toolkit project set up. The first one I made seemed to behave. I made one yesterday and followed the prompts. However, After Effects is missing from the list on SG desktop. I have photoshop and Mari(which is not installed) on there. Where do I need to enable it for that project and what did I do wrong?

2 Likes

Hi Byron!

(First off a quick mention that I moved your post to the Pipeline Integrations category so the right people see it.)

Now, as for getting After Effects to show up in Desktop – you can manage this via Software entities within Shotgun. Specifically, you should be able to add a Software entity for After Effects in Shotgun, and it should then show up in Desktop.

This section of the Toolkit Admin Guide is all about the Software entity, and includes an example for adding your own software.

Take a look, and if you’re still stuck, let us know and we can answer any outstanding questions.

2 Likes


As far as I can tell, that screen looks fine. I’ve screen grabbed the two projects in question. You can see how one shows After Effects and one does not. I’m also still getting all those other products like Nuke, Mari, etc… despite them being disabled in ‘Software.’

4 Likes

Hi Byron –

Thanks for sending along those screenshots. They’re really helpful. I have a couple hunches; bear with me as I give some backstory:

  • The launchers in Desktop are defined via the tk-multi-launchapp.
  • Whe you have a single instance of tk-multi-launchapp defined, with the use_software_entity setting set to true, Toolkit will go through all of the Software entities, evaluate what should be restricted or displayed for a given project based on the Project, Status, User Restrictions, etc fields, and create all the valid launchers in Desktop.
  • The Software entity is actually a newer way of specifying launchers, though. In the classic method, you have an individual instance of tk-multi-launchapp for each desired software launcher, with use_software_entity set to false, and all of its details specified within the app’s configuration settings. Both are supported, and both can work simultaneously.
  • One more piece of info that’s relevant here: when you are using the Software entity, if you don’t specify values for the Mac path, Linux path, Windows path fields, Toolkit will try to auto-detect the given software package by looking in standard locations (as defined by the Software’s Toolkit engine (eg, tk-nuke, tk-aftereffects, etc.)). If it doesn’t find it, it won’t display the launcher in Desktop. Usually, you’ll see these as apps with names like tk-multi-launchmari, tk-multi-launchmotionbuilder in your config.)

So, with all that in mind, these are my hunches and thoughts about what’s going on here:

  • The fact that AE is showing up in one project and not the other, when there’s clearly no project restriction on the Software entity, makes me think that perhaps it’s coming from an individual launcher. I’d check your config for that – if it follows the pattern of the Default Config, then it should be in config/env/includes/settings/tk-multi-launchapp.yml, and should be included into config/env/includes/settings/tk-desktop.yml (more on includes here). I’m guessing that AE was added to the config for The Warrant, but not for Blue Ridge.
  • The same goes for Mari and Hiero showing up when they’re not explicitly enabled in the Software entities. We took some shortcuts with those two, they’re not commonly used, and so we didn’t prioritize setting up their engines to support the Software entity. You’ll notice that they’re not actually listed on your Software page in Shotgun. So, again, you’ll want to remove those individual launchers from your config in the files listed above.
  • A final question is still dangling: why, if you’ve specified AE in your Software entities, is it not showing up on all shows? I think this has to do with the last point – that Toolkit only auto-detects software if it’s in a standard location. Try specifying the path to AE in the relevant Mac/Windows/Linux path fields on the software entity. That should get it to show up. (And if you still have the individual launcher for AE in your config for The Warrant, it’ll actually show up twice – once via Software entity, and once via individual launcher.)

I think that explains all the weirdness here. I know it’s a lot of info, though – let me know if you still have questions and we can unpack further!

3 Likes

I looked at the files you sent paths for. Photoshop nor After Effects appears in the list. However, I also noticed something in SG desktop. The Icon that looks like Photoshop says “Motion Team”. When I clicked on it, it revealed links to both Adobe apps. So, maybe it was there all along but hidden under that group icon? I can click on AE now. It has the wrong icon(red rocket?) but it seems to launch fine. If I want to take out the unused apps, do I need to remove them from the kk-multi-launchapp.yml file?

1 Like

Ah, it looks like you have “Motion Team” specified as the “Group” field value in Shotgun for Photoshop and AfterEffects. You could get rid of that grouping if you’d like.

And yes, you’ll want to remove them from config/env/includes/settings/tk-multi-launchapp.yml, and also remove references to them in config/env/includes/settings/tk-desktop.yml.

2 Likes