Avoid character escape in tk-shotgun engine (web page) command output

For trivial commands attached to entities from the web pages, logging info messages is great.

However, many character escapes appear on that output, even for something as simple as a single quote.

This is happening post the app processing. Checking string length in the app shows its not quoted there. Perhaps this is XML encoding between the shotgun engine and the web page javascript?

How can we prepare output to avoid character escapes in “command output”?

3 Likes

Hi @Rhea_Fischer – can you provide a screenshot of what you’re seeing? Thanks!

1 Like

Sorry just saw this… I’ll get something together for us.

1 Like

Hi @tannaz, this may only happen when debut mode is enabled. If so its interesting but not critical.

1 Like

I have the same, it’s quite annoying actually!

image

2 Likes

Hi all – Just wanted to let you know I’ve put in an internal ticket to track making this output more readable. I’ll let you know when there’s news.

3 Likes

Thanks!

An I can confirm it seems to only happen when debug is enabled.

2 Likes

Yup, I have this too. I think this has been raised before so should already have an internal ticket for it?

2 Likes