Error when playing rv on shotgun

We are testing to use the shotgun pipeline.

I uploaded it to the shotgun without transcoding the mov file.
And I played the mov file uploaded from the shotgun.

However, an error message is output.

ERROR: _processInfoFields: exception: “No field named ‘sg_department’”

Artist department has been assigned.

Didn’t enter because there is no department field when uploading, is there any other problem?

Happy new year!

Hi @nareineru,

What RV version are you using?

Happy new year!

Loney

Thanks Loney for picking it up.

Hi @nareineru I have a ticket thread with you with regard to “disable auto-transcoding”. How about we work on the error in that thread?

Cheers,
Ben

I’m having the same error with regular transcoded by shotgun versions.

The problem is Shotgun does not longer comes with the sg_department field by default in Versions, so you either delete it from shotgun_fields_config_standard.mu or add it as a field to your versions.

Providing that this field is no longer a default one for versions, shouldn’t the plugin for RV come with this field as “optional” and not required? Is actually a way to do this in the shotgun_fields_config_standard.mu ? For compatibility with projects who has them and the ones who don’t?

This other post is related to this:

Thanks a lot in Advance!