Filter My Tasks in Shotgun: File Open

Hello,

I’m trying to filter the tasks under My Tasks in the file open dialog to only show tasks that do not match a certain status. I’ve tried modifying tk-multi-loader2.yml by appending an “sg_status_list” filter like so:

image

This doesn’t seem to have any effect - tasks with the filtered status are still listed under My Tasks. I’m not sure if my syntax is wrong or there’s another issue. Any clarification would be much appreciated, thanks!

1 Like

I tested that on my side and it worked as expected, so I don’t think there is a problem with your filters there unless your task status is not actually ‘fin’.

Could you check to see if the loader is actually using your settings?

If not perhaps one of the following is true:

  • Your not using the config you are modifying.
  • The settings block you are modifying for the loader is not being used in your current environment.

Cheers,
Phil

Hi @philip.scadding ,

Sorry I confused the config I should be changing. I want to change the task filter for the File Open dialog, which would be tk-multi-workfiles2.yml, right? I’ve made this change:

image

I tried both with and without the quotation marks and different task statuses. However, it doesn’t seem that the File Open dialog picks it up:

P.S. I’m using the config I’m editing and my task status is set to “fin” indeed.

1 Like

OK np, yes the tk-multi-workfiles2 settings is what you need to change here.

I can’t see from your screen grab what software you are in, or what configuration block your settings are contained within.

But lets say for example it is Maya and I can see you are in a project context, you would need to edit this settings block:

Also you mentioned originally that you wanted to change the My Tasks tab, but your screenshot of the config is for the Shots tab settings. So you would actually need to add a my_tasks_filters setting out side of the entities block, so you would have something like this:

settings.tk-multi-workfiles2.launch_at_startup:
  my_tasks_filters:
  - [task_assignees, is, '{context.user}']
  - [sg_status_list, is_not, 'fin']
  launch_at_startup: true
  entities:
  - caption: Assets
    entity_type: Asset
    hierarchy: [sg_asset_type, code]
    filters:
    sub_hierarchy:
      entity_type: Task
      filters:
      link_field: entity
      hierarchy: [step]
  - caption: Shots
    entity_type: Shot
    filters:
    hierarchy: [sg_sequence, code]
    sub_hierarchy:
      entity_type: Task
      filters:
      link_field: entity

I’ve not tested that, so it might contain a mistake but I think that is about right.
Additionally, you would need to modify the settings block for the asset_step and shot_step environments if you wanted the tasks to be filtered in them as well, which you probably would.

Thanks @philip.scadding

Again, not sure what I’m doing wrong.

I’m using Nuke, here’s my tk-multi-workfiles2.yml change at startup:

My changes for the Nuke shot step:

And my Shotgun: File Open dialog still not updating with the filters:

1 Like

OK so Nuke by default uses the @settings.tk-multi-workfiles2 settings block, so that might be the issue here:

Try adding it to that settings block instead.

1 Like

Thanks @philip.scadding

I updated my tk-multi-workfiles2.yml as per your recommendation:

image

I also added “my_tasks_filters” for every software/step and it works now, thanks.

1 Like