Found a possible bug with Tracking Setting

I have this error message when trying to create a new asset:
create failed (reason_code 6): Invalid field value, update failed [ 5 - Update failed for [Asset.sg_status_list]: ‘wtg’ is not a valid status. Valid statuses: ‘rdy’, ‘ip’, ‘rev’, ‘apr’, ‘rtk’, ‘hld’, ‘cncl’.]

This bug only happens if I remove the Status “Waiting to start” in Traking Setting > Asset > Status.

Workaround: Put back Waiting to Start status in tracking settings and hide the status.

2 Likes

Hey Ben, just to let you know, I moved this over to the “Shotgun” category, as I think it will get better attention here.
Cheers
Phil

1 Like

Thanks, Phil for put it in the right pool.

Hi @benwall,

You are seeing this error as by default, we set “waiting to start” as the default value for Status field of Asset entity. Once removed, when you create an asset, Shotgun could not find the default value thus throws out the error.

If you do not want to use Waiting to Start , you need to right click on the Status field, and get into the following configure page; Set the default value to something else, and then remove Waiting to Start from the list.

Hope it helps you.

Cheers,
Ben

2 Likes

Hi Ben_xzj,
Default status was already set to “On Hold” by default on all Task Template and field options.

1 Like