How to fix Chrome protocol handler "Always open these types of links" pop up when opening RV through rvlink

bnyzL
Hi after Chrome version 77, the checkbox to always open RV when opening rvlinks is missing, making it very annoying everytime you click Play on RV as Chrome asks for confirmation, after Chrome version 79 there is a special policy (ExternalProtocolDialogShowAlwaysOpenCheckbox) that you can enable to get the checkbox back, this example is for Linux, but you can follow the same approach for win and mac.

Create the folders needed.
mkdir -p /etc/opt/chrome/policies/managed/

Create an empty Json file
touch /etc/opt/chrome/policies/managed/managed_policies.json

In this Json file, put the following content:

{
“ExternalProtocolDialogShowAlwaysOpenCheckbox”: true
}

That’s it! Start Chrome the checkbox should be there.

NOTE: For Chrome versions 77 and 78 there is a workaround, directly add the rvlink protocol handler as an excluded scheme in the Preferences file in ~/.config/google-chrome/Default/Preferences

Like this:
“protocol_handler”:{“excluded_schemes”:{“rvlink”:false}}

7 Likes

Thanks for sharing this tip, @macbeth—it’ll end up helping others! :smiley:

1 Like

Thanks so much! This started popping up for us at the end of last year and we thought we’d have to swap browsers because of it.

1 Like

@frank—check out this thread for possible resolution on your AMI dialog issue. :smiley:

Thanks @johnny.duguid for leading me here, and thanks @macbeth for writing this up!
Unfortunately it isn’t working for me, I’m sure I’m missing something though.
This is my json file:

[frank@spiff]$ cat /etc/opt/chrome/policies/managed/managed_policies.json 
{
“ExternalProtocolDialogShowAlwaysOpenCheckbox”: true
}

I then restarted Chrome (v80) but when I run my AMI I get o checkbox.

image

1 Like

Hi, that should do the trick!
Maybe some permissions issue with the folder or the file?

Check this guide for chromium I believe it has better info than the google one:

Thanks @macbeth, I had a look and the article doesn’t really offer any more info. I made sure the json file is readable by my user id so I have no idea what else to look for.
I copy/pasted all file paths and the json content so typos shouldn’t be the issue.
I also tried the “HomepageLocation” policy from the example page but to no avail.

I might be stuck with confirming every single AMI for now :frowning: