New Project Page - Advanced Form by default

Hi,

Is there a way to access advanced form for new project creation by default when clicking “New project” or at least by URL?

We always use Advanced Form when creating new projects and I want this to be the only way.

At the moment the person that creates the project needs to go to top navigation bar, click “Projects”, scroll all the way to the bottom, click “New Project”, then click “Use the advanced form…”, and only then start filling in the info. Preferably, this would be a single click.

In truth, I would really like to disable the “simplified form” altogether - this one:

The reason is it offers nothing to us, it just makes things more prone to error.

Thanks for any input,
–Aleksandar

1 Like

Hi @koaleksa,

We don’t have an actual preference to make the advanced form default. There is a workaround you might be able to try.

  • When you get to the new Project creation form, Click on the Use the advanced form... link.
  • Once your in the advanced form, customize it to your liking and make sure you set one of the fields as required (name and layout_project are already required, you’d need to add another required field).
  • Save the advanced form
  • Reload your project page and try creating a new project again - the advanced form should load automatically.

Please let me know if this works and is acceptable for you.

1 Like

Hi Patrick,

Unfortunately, it does not work. I’ve set a few fields as required and it still went to the simple form. It even lets me create the project without ever warning me about the required fields. :frowning:

1 Like

Hi @koaleksa,

Thanks for getting back. Another workaround to try out. Here are the steps:

  • Log in as admin (or users who are using admin permission)
  • Go to Admin menu->Default Layouts->Project->Project Form
  • Set up certain fields as required from that page
  • Save Form from the gear icon

Load the page and when you click on New Project option from the Projects dropdown menu, it will automatically prompt you with the advanced project creation form.

Try it out and let us know if it works on yours.

2 Likes

Hi @Ben_xzj,

I’m sorry to report it doesn’t. I’ve followed those exact steps on our site and it still prompts me with the regular form.

1 Like

Hi @koaleksa,

Could you please Direct Message me your Shotgun Site ? It should work as I tried on multiple sites.

Click on my avatar and message me the site URL please.

1 Like

Hi @koaleksa,

Thanks for trying it out. Unfortunately it’s indeed not working on your site. It seems the issue remains with long existing shotgun site which came from previous template, not a problem for newly-registered ones.

The workaround is the right way to configure the Advanced Project Creation Form, but it’s not working for long existing sites.

Sorry for letting you down again. We probably need to wait for the fix.

2 Likes

Hi,

Thanks for confirming – started thinking I’ve gone mad there for a moment. :smiley:

We will survive 'till it gets fixed, no worries. :slight_smile:

Cheers,
Aleksandar

2 Likes

Thanks @koaleksa. Will let you know if any progress of it.

2 Likes