OCIO GPU, OCIO V2, LUT resolution and artefacts

Hello guys,
When we load an ACEScg exr in Rv and display it in P3D65 (ACES) using OCIO, we can some see artefacts in the sky :
sky_banding_gpu
That do not appear in the Nuke Viewer (using OCIO as well) :
sky_nuke_cpu
We believe this is related to the use of GPU LUTs in Rv. We have tried to increase the resolution of the GPU LUT but could not get a match below a resolution of 512x512x512 (as opposed of 32x32x32 now). Which makes this solution very heavy for the users.

We have some questions :

  • Any plans on implementing OCIO V2 ? And if yes, when ?
  • Any plans on running LUTs in CPU (like Nuke) ?
  • Is it a matter of implementing OCIO differently in our pipeline ? Or using a shaper log space ?

Many thanks,

Chris

2 Likes

Would love know how RV banding with OCIO could be improved. I believe the same issue was described before in this old post https://support.shotgunsoftware.com/hc/en-us/community/posts/115004864893-Strong-banding-with-OCIO-in-RV-known-OCIO-issue-

Thanks Luke for the link ! This thread was from more than three years ago. Hopefully we could expect some improvements soon (OCIO V2 maybe ?).

Regards,
Chris

Hello again,
it looks like that Kevin @ Autodesk gave a presentation at the ASWF Review and Approval meeting a week or so ago about their line of products which did indicate a migration to OCIO v2 as a goal for future versions of RV.

Could we anyone confirm that ? Can we have access to the meetings’ notes ? Is there any roadmap ?

Regards,
Chris