Published texture UDMIs from Mari not showing in "Publishes" inside of Loader

Hello. I am fresh in Shotgun. And still figuring out how everything works …

Hope there are some Mari user that might be able to help me figuring out a proper workflow with Mari Texturing Task … It looks so easy in the Youtube demo. Got it to the point where I successfully published files (exported into correct folder). But cant see them inside Maya Loader. But I can see files in Shotgun Panel under Publishes.

The other thing is regarding setting up how things are beeing published (file type, resolution, color space etc), because right now it is always publishing it in 1K TIFF format.

Thanks in advance for any help. :slight_smile:

1 Like

Hey @vietato,

Sounds like you just need to add the Mari published file type to the loader action mappings under the Maya section, make sure the Published file type name matches;

likely adding something like;

Tiff: [texture_node, image_plane]
or
Mari Export: [texture_node, image_plane]

Or whatever your published file type name is.

Check out out doc for more info;

-David

3 Likes

thanks. will give it a try!

3 Likes

I think I don’t fully grasp it. :stuck_out_tongue: but did find the yml where it shows the publishing setting … is that also where I can change it to something different? and in case I can. how to do it without messing up things. …

but back to the other problem regarding Loader. I did try to add some lines … but I am not sure if that is correct what I did. (see attached screenshot of the yml’s) … And I don’t know yet, what I need to compare it with. Can you tell me where the “action_mappings” are beeing defined? like how does it understand for example “Mari Export”

1 Like

Hello. I was wondering, if my current “default” setup is missing something, or is it normal that the loader is not able to automatically see Mari’s published textures, and that it needs to be configured manually? I saw that there is already a line that says:

Texture: [texture node, image plane]

What does that do? is that the same like telling it to read texture files from mari?

1 Like

another question. :slight_smile: would it be possible to ask for a TK update that already has the feature to be able to Load texture files from Mari? because it would be awesome that this could be already a standard … especially for people like me, who is not very good in setting up things :slight_smile: maybe a part of a new update? at least I know how to update TK’s now :stuck_out_tongue:

1 Like

hello. just double checking if anyone could help? I still haven’t figured out to make it work in Maya or any other application (Photoshop) to be able to load the published Textures from Mari.

1 Like

Hi sorry this dropped off our radar.

I just took a look at the PublishedFileTypes on your site, and I can’t see a Mari Export or a tif PublishedFileType as you have them written in the Maya Loader settings.

There is a Tif File PublishedFileType on your site however so maybe your Mari publishes are falling under different types?

Best
Phil

2 Likes

Hi Philip. Thanks for the quick response. I found the PublishedFileTypes on our site. Does it mean I just need to add a new Type with the name Mari Export (see attached)?

Because I am not sure about things I can do or shouldn’t do … :slight_smile:

1 Like

If you add a PublishedFileType manually through the UI, it won’t change the type the published file is getting assigned to. You would also need to modify the publish settings to make sure that the file extension you were publishing created the appropriate type.

What is the extension of the file you are publishing in Mari, and what PublishedFileType is the PublishedFile being given at the moment?

1 Like

Regarding exported Textures from Mari. It could be different file types. it will be most likely always several UDMIs (sequences) & file type could be exr, tif, png, jpg

1 Like

at the moment in mari publisher … it has a default publish setting as tif. Which was the other question, where and how to customize the publish setting. usually it can be done within mari. but through shotgun we are not sure how.

1 Like

Hi @vietato,

Looking at your site the PublishedFileType coming from Mari are UDIM Image and Tif File, these are the published file types that you want to add to the loader hook.

Published_texture_UDMIs_from_Mari_not_showing_in__Publishes__inside_of_Loader_-Pipeline_Integrations-_Community___Shotgun

If you look at your Published Files Page on your project you will see the files and their type.

So you would be adding;

UDIM Image: [texture_node, image_plane]
Tif File: [texture_node, image_plane]

To your maya loader settings noted above.
Though looking through docs it seems the the UDIM one is the default.

-David

1 Like

thanks. I also just realized that there is a UDIM Image … will give it another try by adding those.

just to double check. I will change it in the tk-multi-loader2.yml inside the cloned config folder right? and then I will push it in Command Prompt. that’s the proper way to do it?

1 Like

Hi @vietato,

You should just need to add those published file types to the loader2 settings in your project config on disk, <PROJECT_CONFIG>/env/includes/settings/tk-multi-loader2.yml

Restart SG Desktop and Launch Maya.

-David

1 Like

ah. ok. thanks. good to know. cause I just did in in the clone folder and pushed it … didn’t work. :smiley:

1 Like

No Worries :slight_smile:

1 Like

It seems that it still doesn’t work … :confused:

Overall shotgun knows that there is a UDIM texture image. The SG Breakdown listed the new version (which I loaded from my task publishes … which will not be visible if someone else was doing it) … and I could update it to the newest version. but in the Loader there is still no “Texture Task” published files listed. Maybe it doesn’t know that there is a “Texture Task” ?

1 Like

Hey @vietato,

Looking at your screenshot, something is not set correctly as even if you don’t have any files of that file type it should still show in the “Filter by Published File Type” box in the bottom left.

See in my example I just tested has UDIM Image as a filter option even though I don’t have any available.

Maybe it would be faster if you write us a ticket to support@shotgunsoftware.com and send us your .zipped config and we can have a closer look.

Cheers,
David

1 Like

oki. thanks. Will try to do a Ticket.

2 Likes