Publisher thumbnail PySide2 grabWindow Error

Hi All,

We’re using the Publisher in Maya and have an error when trying to create a thumbnail:

# File read in 0.067 seconds. #
# Traceback (most recent call last):
# File "/app/package/int/tk_core/0.19.14-sps.1.0/studio/install/app_store/tk-multi-publish2/v2.5.2/python/tk_multi_publish2/thumbnail.py", line 112, in _on_screengrab
# pixmap = screen_grab.ScreenGrabber.screen_capture()
# File "/app/package/int/tk_core/0.19.14-sps.1.0/studio/install/app_store/tk-framework-qtwidgets/v2.9.2/python/screen_grab/screen_grab.py", line 188, in screen_capture
# pixmap = get_desktop_pixmap(tool.capture_rect)
# File "/app/package/int/tk_core/0.19.14-sps.1.0/studio/install/app_store/tk-framework-qtwidgets/v2.9.2/python/screen_grab/screen_grab.py", line 337, in get_desktop_pixmap
# desktop.winId(), rect.x(), rect.y(), rect.width(), rect.height()
# ValueError: # 'PySide2.QtGui.QPixmap.grabWindow' called with wrong argument values:
# PySide2.QtGui.QPixmap.grabWindow(479, 514, 232, 437, 243)
# Found signature:
PySide2.QtGui.QPixmap.grabWindow(int, int=0, int=0, int=-1, int=-1)

The version of Maya is 2020.1.
We’re on CentOS 7.6.

I found this thread on the subject but we have a newer version of maya and the version for Pyside2 and PySide2.QtCore are both 5.12.5.
Did anyone encounter the same issue?

There is a workaround in shotgun for linux, just install ImageMagick:
yum install ImageMagick

1 Like

Check out this PR for tk-framework-qtwidgets

It might be worth bumping the Shotgun team on it