RV isn't playing every frame of my file using VP9 for the video codec

Hello,

I have some .mp4 videos that are using Google’s VP9 codec for video. RV only plays about 1 in every 30 frames. I suspect it is playing every key frame and failing to update the in-between frames. VLC plays the media fine so I know the frames are in there…

Is there anything I can change in RV to get it to play correctly? Is there a setting that I need our engineers to change when they create these movies? I don’t want to transcode all of them but doing so with ffmpeg is one option I’ve found to get them to play.

1 Like

Hi Stewart!

Unfortunately we don’t officially support VP9 playback in RV. I’ll put in a feature request to our product managers to support it.

If you are willing to take legal responsibility for acquiring a license yourself, then you can follow the directions in the src/mio_ffmpeg/README file included in your RV install to re-compile the ffmpeg-based plugin with support for that codec enabled.

Please note that mio_ffmpeg wasn’t working starting with RV 7.5.x and we’ve just fixed it in 7.7.1. If you’d like to have a beta version of 7.7.1 before it’s released, please let me know.

Thanks,
Alexa

1 Like