RV version change compatiblity

# rant mode

You all know that I love you guys very much, but the lack of compatibility between RV versions is really getting frustrating. We have to support multiple versions of our tools to support changes in RV which are not forwards or backwards compatible. For example in the new 7.9 RV, the rvui.mu contains code which, if not present, will crash 7.9. And if it IS present, it will crash 7.8. This happens almost every release, and because we have to test all our tools with each version - there’s a good chance something doesn’t work any more - we can’t just patch and release. We have to manage each release for each client because they might be on a different version of RV and upgrading can be a problem in a calibrated screening room where touching anything on the computer is a 2 hour meeting.

# rant mode end

Thanks!
Den

5 Likes

Hi @dennisserras,

Thanks for posting and much appreciated for your feedback to our RV development team. I’ll ensure it gets forwarded to them.

Cheers,
Ben

3 Likes