RVSDI AJA driver detection

Our systems team is running into a spot of trouble getting RV to detect the AJA Kona4 card. They’ve confirmed the drivers are properly installed per the AJA docs.

Version 7.3.2, built on May 17 2019 at 08:30:05 (HEAD=d5d93d93c). (L)
Copyright © 2017 Autodesk, Inc. All rights reserved.

ERROR: Cannot open: Driver version 0 older than SDK version 14

ERROR: Cannot open: Driver version 0 older than SDK version 14

libDeckLinkAPI.so: cannot open shared object file: No such file or directory
INFO: loaded shotgun config module ‘shotgun_fields_config_standard’ (/opt/rv-Linux-x86-64-7.3.2/plugins/Mu/shotgun_fields_config_standard.mu)
AJA: AJA: no devices found
INFO: BlackMagic-SDI: Decklink driver failed to initialize or is not installed

Before we escalate to an official support ticket, anything obvious we might be missing here?

3 Likes

Hey Nico,

You’ll want to make sure your AJA driver and firmware match the version of the SDK that RV was compiled with. AJA drivers are not considered to be backwards compatible so you likely have a newer driver than the SDK RVSDI was compiled with.

In the RV>Preferences>Video tab in RVSDI, it will indicate at the bottom what SDK version that version of RV was released with. At the time of this post, RVSDI needs the AJA 14.2.x drivers and the associated firmware (if you downgrade your driver, make sure to also downgrade your firmware to match).

Can your systems team validate what driver version they have installed?

3 Likes