Shotgun Desktop Issue on CentOS 8.x

Hi,

Its been a while since I’ve checked out Shotgun Toolkit updates so I setup a new test site, downloaded the desktop app and setup a default pipeline configuration. All of this is on a CentOS 8 machine with the most recent Shotgun releases as of today. After the pipeline config setup is complete, Shotgun Desktop seems to error out when trying to load the project information:

2020-11-05 11:30:49,173 [   DEBUG] Starting RPC server
2020-11-05 11:30:50,237 [   DEBUG] : Resolved hook expression (associated with setting 'hook_launch_python'): '{self}/launch_python.py' -> ['/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/hooks/launch_python.py']
2020-11-05 11:30:50,238 [   DEBUG] Loading environment data from path: /home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-config-basic/v1.3.15/env/site.yml
2020-11-05 11:30:50,255 [   DEBUG] launching '/home/sshrestha/apps/vfx/Shotgun/Python' '/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/bootstrap.py' '-d' '/tmp/tmpg_BUEv.pkl' '-u' '/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/python/utils/bootstrap_utilities.py'
 [   ERROR] Unexpected error while launching Python:
Traceback (most recent call last):
  File "/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/python/tk_desktop/desktop_window.py", line 1507, in _start_bg_process
    utilities_module_path=utilities_module_path,
  File "/home/sshrestha/.shotgun/noizfactory/site.basic.desktop/cfg/install/core/python/tank/platform/bundle.py", line 582, in execute_hook
    resolved_hook_paths, self, None, base_class=base_class, **kwargs
  File "/home/sshrestha/.shotgun/noizfactory/site.basic.desktop/cfg/install/core/python/tank/hook.py", line 631, in execute_hook_method
    ret_val = hook_method(**kwargs)
  File "/home/sshrestha/apps/vfx/Shotgun/Resources/Desktop/Python/bundle_cache/app_store/tk-desktop/v2.5.9/hooks/launch_python.py", line 62, in execute
    subprocess.Popen(args, startupinfo=startupinfo, close_fds=True)
  File "/home/sshrestha/apps/vfx/Shotgun/Python/lib/python2.7/subprocess.py", line 394, in _init_
    errread, errwrite)
  File "/home/sshrestha/apps/vfx/Shotgun/Python/lib/python2.7/subprocess.py", line 1047, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied

While debugging this, I tried running tank and that also failed:

Cannot find interpreter /home/sshrestha/apps/vfx/Shotgun/Python defined in config file /home/sshrestha/workspace/storage/configs/fractaldemo/config/core/interpreter_Linux.cfg!

The path “/home/sshrestha/apps/vfx/Shotgun/Python” that’s setup in the interpreter config file seems wrong as it points to the shotgun python directory and not the python executable itself. So, I updated that config to point the right executable file “/home/sshrestha/apps/vfx/Shotgun/Python/bin/python” and everything seems to work fine now. I don’t remember having to do this additional step during toolkit setup in the past so I’m wondering if this is something specific to the newer CentOS/RHEL 8.x versions?

CentOS 8.2.2004 (kernel 4.18.0-193.28.1.el8_2.x86_64)

Thanks,
Sachin

1 Like

I have the same issue on the latest kernel for Centos 8, while it worked int he previous Centos8 kernel.

I have the same [OSError: [Errno 30] on mac 10.13.6.
Any help or new idea in the new year ;)?
Thanks

We’ll discuss this internally and respond back here.

@Tanguy were you able to solve the issue by following the same steps as @sachin.shrestha?

@Francesc_Macià it looks like your error might be a bit different? You have the error code 30 rather than 13. If it is different we can start a separate topic for that one.

Hi Philip, sorry my typing mistake the error code is 13!

1 Like

OK we’ve managed to recreate the issue with that version of MacOS as well. Newer versions of MacOS don’t appear to have the problem. We’ve created an internal ticket for this and can update this thread when we have more information.

As for CentOS 8 we don’t currently support that OS, but it’s possible that if we find a fix for MacOS then it might also apply to CentOS 8 as well.

3 Likes

I did not try that, I just used Mate desktop instead of the regular gnome. My issue was that the SG toolkit was unable to display the icone within the regular gnome desktop shipped with Centos8.
Now my setup works fine with Centos8, BUT on Mate Desktop.