Shotgun Integration Error

Hi!

I get an “Shotgun Integration error” when launching Shotgun Create on MacOS Mojave 10.14.5.

It says: "Cannot launch websockets. Shotgunlocalhost certificates not enabled). Shotgun desktop is running BTW.

Cheers!

Øyvind

3 Likes

@oyvind, yeah! Community@Shotgu! We are also excited about the new community. Let’s all work together to keep it grow.

Could you please share with us your Shotgun site or PM me if you prefer so that I could hop over and tweak some hidden config?

Cheers,
Ben

3 Likes

Hi! Our Shotgun site is mod edit: removed site URL. Thanks!

Cheers,

Øyvind

2 Likes

Hi oyvind,

I’ve completed the tweak on your site. Could you please try to re-launch Shotgun Create and see if everything works fine now?

Cheers,
Ben

3 Likes

Seems to work perfectly now! Thanks :smiley:

Øyvind

4 Likes

Glad to know it works now. it’s due to a hidden feature which is not abled. We plan to switch it to be enabled by default in future release, which will help avoid the issue.

Alright, have fun Shotgunning!

5 Likes

@Ben_xzj , sorry to bother. Would you be able to point us to the hidden feature?
If not, due to hidden meaning not available for us to edit at this moment, would you be able to sort out our site please :slight_smile: .
mod edit: removed site URL

I would really like to start looking into SG Create and get our departments up and running with it.

Thanks for your time.
Malcolm v A

1 Like

@malcolm.vanaardt, no danger to bother us anytime, we are here to support you. I’ve tweaked the hidden preference (which is not avilable to clients) for your site. Give Shotgun Create a go now.

And here is some fancy Create toturials you may want to check out.: https://support.shotgunsoftware.com/hc/en-us/articles/360025994053-Shotgun-Create-Video-Training

And for others who might encounter this issue. Do not heistate to reply this thread with your Shotgun site, I’m more than happy to help.

Starting from SG 8.5 hopefully, we will have this hidde cofig set as enabled by default, which means you won’t get this integration error any more.

Have fun shotgunning!

3 Likes

Awesome, Thanks @Ben_xzj !

1 Like

Hi,

I have the exact same error message on our shotgun site : mod edit: removed site URL
Could you fix it ?

Regards

1 Like

Hi @donat! I have updated the setting so this Create error should be gone now. You may have to log out of regular Shotgun and log back in for the setting to take effect.

Cheers,
Beth

2 Likes

Hi,

Same error for Shotgun create here. Our shotgun site: mod edit: removed site URL. Could this be fixed?

Kind Regards

1 Like

@SHCyborn should be fixed now. Please reach out if you have any more trouble here.

Cheers,
-Tommy

1 Like

Hi,
Same error here. Our site:
mod edit: removed site URL

Done, @Shervinion. Could you please try it again?

Works. Thank you.

Hey everyone—I’m thrilled to see the activity and support in this thread!

I do want to recommend a security best practice. While your Shotgun site is secured through various authentication approaches, I would highly suggest that—when sharing your site URL—to send it to us via a Direct Message. By keeping your site URL out of the public eye, you’re reducing the visibility of the site and making it harder for a nefarious party to find it.

I’ve already gone through this thread and edited out any site URLs, so no need to take action.

Sending a DM is super easy and happens in the same message compose window in the forum.

You can send a direct message by replying to the thread via the REPLY button, clicking the arrow icon in the compose window, and selecting new message. Here’s an image for ref of what that part of the forum looks like:

Address the DM to the person you want, but if you’re not sure who to send to, you can address it to me—your community manager—and I’ll handle getting it to the right person.

Drop me a message if you have any questions or concerns on this front. :partying_face:

4 Likes

Hi everybody! I wanted to follow up on this thread and let you know that as of Shotgun 8.5 the preference that needed to be on for Create compatibility has been turned on for all hosted sites. If anybody is still seeing issues, they should get in touch with us since there is probably some other issue going on.

3 Likes