Shotgun Python API v3.1.0 released -- Python 3 support!

Hey everyone,

We’re happy to announce that we’ve released v3.1.0 of Shotgun’s Python API! This release adds support for Python 3, while maintaining compatibility with Python 2.x.

With the VFX Reference Platform’s CY2020 mandating the use of Python 3.7.x, we are expecting to see content creation software embedding Python 3 in the very near future. This is our first step towards supporting those forthcoming releases, with more to come in the future as we move our attention to Toolkit.

As always, feel free to reach out to our support team if you have any questions or concerns!

20 Likes

For those of you new to Shotgun who might not already be using the Python API, see the documentation linked here!

4 Likes

those docs are awesome :wink:

5 Likes