Shotgun Python API v3.2.6 released -- Certificates

Hey All

Just to say we have released v3.2.6 of the Shotgun Python API. This update should prevent some of the connection issues where the API is unable to communicate with Shotgun or unable to download and upload media from AWS.

The update bundles certificates with the API which it now uses by default. You can still override the certificates by setting the SHOTGUN_API_CACERTS environment variable or by passing the certs file as an argument to the API.

By bundling the certificate with the API we can be sure that the correct certificates are present at the time of release. This does mean however that if in the future we need to update the certificates then a new release of the API will be created. When that happens users will need to update to the latest API version or point an updated certificate file if updating the API is not convenient.

Best,
Phil

4 Likes