Software showing up in desktop but not in software list

Just noticed I have mari showing up in my shotgun desktop launcher however not in my software list on the shotgun site. I need to configure the software to be disabled for all users since my division of the company wont be using mari but without it in the software list I don’t know how I might do that. Looks like the same thing is true for Hiero. Any idea how I might fix this?

2 Likes

Hey Joe!

Some DCCs (Mari, Hiero, Mobu, etc.) that we have integrations for do not support the Software entity, and have to be managed within your pipeline configuration.

Some backstory here: setting up launchers via Software entity in Shotgun is a relatively new development; originally, you had an tk-multi-launchapp instance in your config for each engine/DCC, and that instance contained all the per-DCC configuration (path to software, engine, etc.)

When we moved to the Software entity, there were a few low-usage integrations that we didn’t prioritize porting, and they’re still in that state.

So, in the Default Config, they have their own launchapp instances. They’re defined in config/env/includes/settings/tk-multi-launchapp.yml, and included into config/env/includes/settings/tk-desktop.yml (among other places).

So, to get them out of Desktop, you can just remove the include lines from the latter file. In config/env/includes/settings/tk-desktop.yml, you’ll see the following block:

settings.tk-desktop.project:
  apps:
    tk-multi-pythonconsole:
      location: "@apps.tk-multi-pythonconsole.location"
    tk-multi-devutils:
      location: "@apps.tk-multi-devutils.location"
    tk-multi-launchapp: "@settings.tk-multi-launchapp"
    tk-multi-launchhiero: "@settings.tk-multi-launchapp.hiero"
    tk-multi-launchmari: "@settings.tk-multi-launchapp.mari"
    tk-multi-launchmotionbuilder: "@settings.tk-multi-launchapp.motionbuilder"
    tk-multi-publish2: "@settings.tk-multi-publish2.standalone"
    tk-multi-screeningroom: "@settings.tk-multi-screeningroom.rv"
    ...

Just remove the tk-multi-launchhiero and tk-multi-launchmari lines from that block, and they should disappear in Desktop.

3 Likes

Ahh perfect thank you so much for the info good to know. This worked perfectly thank you!

3 Likes