Connection Entity - help with the 'advanced' tab settings

Hi,

I’m trying to make a list page displaying a connection entity following this section of the Shotgun Admin Guide: Enabling-a-custom-entity

But I cannot make it work, the connection entity does not show in the ‘other’ pages menu.
(it works perfectly with the ‘AssetShotConnection’ example of the guide)

The two entities, as they appears in the Entities tab of the Site Preferences page:

  • Plateau (CustomEntity02)
  • Location (AssetLibrary)
    The multi-entity link as it appears on the Fields page:
    Plateaus <-> Locations custom_entity02_sg_locations_custom_entity02s multi_entity
    an on the ‘Manage Columns’ window:
    custom_entity02_sg_locations_custom_entity02s

In the field ‘Enable List Pages for Connection Entity Types’ of the ‘Advanced’ tab of 'Site Preferences:
CustomEntity02_sg_locations_Connection

I tried several variations using the entity names or they display names with no luck…
What am I doing wrong ?

Thanks for your help !

Hey Fab,

Assuming you’ve created a “Join field” on the Plateau and Location connection entity…

  1. Go to a Location detail page and click on the “Plateaus” tab (or alternatively, go to a Plateau detail page and click on the “Locations” tab).
  2. Click on “Fields” button in the menu and choose “Configure Columns…”
  3. Scroll down until you see “JOIN FIELDS” and expand this section to show a list of fields
  4. Hover over the field and you’ll see reference to the Connection Entity name

Attaching a screengrab as an example. Hope this helps!!

Join Field|526x500

Stephen

Thanks Stephen!

The thing is, there is no JOIN FIELDS section in my ‘configure Columns’ panel. I checked twice.
I can see a ‘Plateaus <-> locations’ field higher in the list but no ‘JOIN FIELD’ section.
Something must be wrong with the link but I cannot figure what I’m messing…

Any idea ? I did spent hours on this one !!!

thanks for your help,
Fab

Hey Fab, I came across the same problem (no Join Field) when creating this screengrab. I recommend creating a test Join Field. When you’re in the “Plateaus” tab in the Locations detail page, click on the “Fields” button in the menu and scroll down below the Audit Fields, and you should see something akin to “LOCATION-SPECIFIC FIELDS” and an option to “Add New Plateau-in-Location Field…”

Once you create this join field, you’ll be able to follow steps above to get the connection entity name! :crossed_fingers:

Note to Autodesk/Shotgun @Beth for vis: The screengrab in Section 5 of this documentation is wrong and mis-leading (and can sadly lead to hours of wasted time!): Enabling a custom entity – Shotgun Support

Stephen

Thank you very much Stephen,
but that doesn’t solved my issue…

I did ‘Add New Plateau-in-Location Field…’,
then was able to get the connection entity name from ‘Configure Columns’:
joinField

and report it in the ‘advanced’ tab of the prefs:
enableTab

But the expected page does not show up in the ‘other’ menu.

@Autodesk/Shotgun Support could you please explain how it works ?
the documentation is really mis-leading on this.

thanks,
Fab